preload-yang

Application Support

HMRC Basic Tools & MTD Changes

At Synergy Technology, we have observed that several sites have as yet not been in touch to ensure their Pegasus Opera 3 systems are successfully updated. It is essential to update your system to achieve compliance with HMRC regulations, so be sure to contact us right away.

Fraud Prevention

HMRC has ruled that all sites must comply with regulations pertaining to fraud prevention. This means that your software must be updated to version 2.70 in readiness for this change. Failure to comply with the new regulations may result in HMRC rejecting your submitted VAT Returns.

Although HMRC has not as yet stipulated when VAT Returns may be rejected for non-compliance, it is extremely important that customers who send MTD VAT Returns upgrade their software immediately to avoid rejection upon submission.

Do I Need to Upgrade?

All versions earlier than 2.63 will require upgrading to ensure you are ready for HMRC Fraud Prevention to come into force. If your version requires an upgrade, please book your appointment in with our engineers today*.

If you are unsure whether your Opera 3 system requires an upgrade, don’t hesitate to contact the Synergy Technology team. We will be happy to assist you in any way possible.

*Please note: this upgrade will take approximately 2 hours to complete, at a cost of £198.00 + VAT.

Contact Synergy Technology Right Away

It is essential to keep your Opera 3 system up to date to ensure HMRC compliance. Failure to do so may result in your VAT Returns being rejected and cause considerable disruption to your business.

Please contact the Synergy Technology team at the earliest opportunity to prevent any complications that may occur.

Call our friendly and knowledgeable team now on 0345 456 0050. Alternatively, be sure to contact your Synergy Technology account manager at your convenience.

Pegasus Opera 3 Payroll updates. for 2020 - Synergy Technology.